Chapter 16. Ports

Table of Contents
Currently Supported Platforms
Unsupported Platforms

This manual describes version 6.5 of Postgres. The Postgres developer community has compiled and tested Postgres on a number of platforms. Check the web site for the latest information.

Currently Supported Platforms

At the time of publication, the following platforms have been tested:

Table 16-1. Supported Platforms

OSProcessorVersionReportedRemarks
AIX 4.3.2RS6000v6.51999-05-26(Andreas Zeugswetter)
BSDIx86v6.51999-05-25(Bruce Momjian
FreeBSD 2.2.x-4.0x86v6.51999-05-25(Tatsuo Ishii, Marc Fournier)
DGUX 5.4R4.11m88kv6.31998-03-01v6.4 probably OK. Needs new maintainer. (Brian E Gallew)
Digital Unix 4.0Alphav6.41998-10-29Minor patchable problems (Pedro J. Lobo)
HPUXPA-RISCv6.41998-10-25Both 9.0x and 10.20 (Tom Lane, Stan Brown)
IRIX 6.5MIPSv6.41998-12-29IRIX 5.x is different (Mark Dalphin)
linux 2.0.xAlphav6.3.21998-04-16Mostly successful. Needs work for v6.4. (Ryan Kirkpatrick)
linux 2.0.x/libc5x86v6.41998-10-27(Thomas Lockhart)
linux 2.0.x/glibc2x86v6.51999-05-24(Thomas Lockhart)
linux 2.0.xMIPSv6.41998-12-16Cobalt Qube (Tatsuo Ishii)
linux 2.0.xSparcv6.41998-10-25(Tom Szybist)
linuxPPC 2.1.24PPC603ev6.41998-10-26Powerbook 2400c (Tatsuo Ishii)
mklinux DR3PPC750v6.41998-09-16PowerMac 7600 (Tatsuo Ishii)
NetBSDarm32v6.51999-04-14(Andrew McMurry)
NetBSD/i386 1.3.2x86v6.41998-10-25(Brook Milligan)
NetBSDm68kv6.4.21998-12-28Mac SE/30 (Mr. Mutsuki Nakajima, Tatsuo Ishii)
NetBSD-currentNS32532v6.41998-10-27small problems in date/time math (Jon Buller)
NetBSD/sparc 1.3HSparcv6.41998-10-27(Tom I Helbekkmo)
NetBSD 1.3VAXv6.31998-03-01(Tom I Helbekkmo)
SCO OpenServer 5x86v6.51999-05-25(Andrew Merrill)
SCO UnixWare 7x86v6.51999-05-25(Andrew Merrill)
Solarisx86v6.41998-10-28(Marc Fournier)
Solaris 2.6-2.7Sparcv6.41998-10-28(Tom Szybist, Frank Ridderbusch)
SunOS 4.1.4Sparcv6.31998-03-01Patches submitted (Tatsuo Ishii)
SVR4MIPSv6.41998-10-28No 64-bit int compiler support (Frank Ridderbusch)
Windowsx86v6.41999-01-06Client-side libraries or ODBC/JDBC. No server yet. (Magnus Hagander
Windows NTx86v6.51999-05-26Working with the Cygwin library. (Daniel Horak)

Platforms listed for v6.3.x and v6.4.x should also work with v6.5, but we did not receive explicit confirmation of such at the time this list was compiled.

Note: For Windows NT, the server-side port of Postgres has recently been accomplished. The Cygnus library is required to compile it.